Debian DSA-3581-1 : libndp - security update

Medium Nessus Plugin ID 91199

Synopsis

The remote Debian host is missing a security-related update.

Description

Julien Bernard discovered that libndp, a library for the IPv6 Neighbor Discovery Protocol, does not properly perform input and origin checks during the reception of a NDP message. An attacker in a non-local network could use this flaw to advertise a node as a router, and cause a denial of service attack, or act as a man-in-the-middle.

Solution

Upgrade the libndp packages.

For the stable distribution (jessie), this problem has been fixed in version 1.4-2+deb8u1.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=824545

https://packages.debian.org/source/jessie/libndp

https://www.debian.org/security/2016/dsa-3581

Plugin Details

Severity: Medium

ID: 91199

File Name: debian_DSA-3581.nasl

Version: 2.7

Type: local

Agent: unix

Published: 2016/05/18

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 8.1

Temporal Score: 7.1

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libndp, cpe:/o:debian:debian_linux:8.0

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/05/17

Reference Information

CVE: CVE-2016-3698

DSA: 3581