F5 Networks BIG-IP : ImageMagick vulnerability (K29154575)

High Nessus Plugin ID 91143

Synopsis

The remote device is missing a vendor-supplied security patch.

Description

The LABEL coder in ImageMagick before 6.9.3-10 and 7.x before 7.0.1-1 allows remote attackers to read arbitrary files via a crafted image.
(CVE-2016-3717)

Note : This vulnerability is one of the series of vulnerabilities known as ImageTragick.

Solution

Upgrade to one of the non-vulnerable versions listed in the F5 Solution K29154575.

See Also

https://support.f5.com/csp/article/K29154575

Plugin Details

Severity: High

ID: 91143

File Name: f5_bigip_SOL29154575.nasl

Version: 2.19

Type: local

Published: 2016/05/16

Updated: 2019/01/04

Dependencies: 76940

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.1

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:N/A:N

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 5.5

Temporal Score: 5

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:f5:big-ip_application_acceleration_manager, cpe:/a:f5:big-ip_webaccelerator, cpe:/h:f5:big-ip

Required KB Items: Host/local_checks_enabled, Host/BIG-IP/hotfix, Host/BIG-IP/modules, Host/BIG-IP/version, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2016/05/13

Reference Information

CVE: CVE-2016-3717