OpenSSH 6.8p1 - 7.x < 7.1p2 ssh_packet_read_poll2() Packet Handling DoS

Medium Nessus Plugin ID 90924


The SSH server running on the remote host is affected by a denial of service vulnerability.


According to its banner, the version of OpenSSH running on the remote host is 6.x equal to or greater than 6.8p1 or 7.x prior to 7.1p2. It is, therefore, affected by a denial of service vulnerability due to an out-of-bounds read error that occurs when handling packets. A remote attacker can exploit this to crash the service or disclose memory contents.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to OpenSSH version 7.1p2 or later.

See Also

Plugin Details

Severity: Medium

ID: 90924

File Name: openssh_71p2.nasl

Version: $Revision: 1.2 $

Type: remote

Family: Misc.

Published: 2016/05/05

Modified: 2016/05/12

Dependencies: 10267

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:openbsd:openssh

Required KB Items: Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/01/14

Vulnerability Publication Date: 2016/01/14

Reference Information

CVE: CVE-2016-1907

BID: 81293

OSVDB: 132882