HP Data Protector 7.0x < 7.03 build 108 / 8.1x < 8.15 / 9.0x < 9.06 Multiple Vulnerabilities (HPSBGN03580) (Bar Mitzvah)

critical Nessus Plugin ID 90796
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host is affected by multiple vulnerabilities.

Description

The version of HP Data Protector installed on the remote host is 7.0x prior to 7.03 build 108, 8.1x prior to 8.15, or 9.0x prior to 9.06. It is, therefore, affected by the following vulnerabilities :

- A security feature bypass vulnerability exists, known as Bar Mitzvah, due to improper combination of state data with key data by the RC4 cipher algorithm during the initialization phase. A man-in-the-middle attacker can exploit this, via a brute-force attack using LSB values, to decrypt the traffic. (CVE-2015-2808)

- A flaw exists due to a failure to authenticate users, even with Encrypted Control Communications enabled. An unauthenticated, remote attacker can exploit this to execute arbitrary code. (CVE-2016-2004)

- Multiple overflow conditions exist due to improper validation of user-supplied input. An unauthenticated, remote attacker can exploit these issues, via specially crafted 'User Name' or 'Domain' field in an EXEC_BAR request, to cause a stack-based buffer overflow, resulting in a denial of service or the execution of arbitrary code. (CVE-2016-2005, CVE-2016-2006)

- An overflow condition exists due to improper validation of user-supplied input. An unauthenticated, remote attacker can exploit this, via specially crafted EXEC_SCRIPT request, to cause a stack-based buffer overflow, resulting in a denial of service or the execution of arbitrary code. (CVE-2016-2007)

- An unspecified flaw exists that allows an unauthenticated, remote attacker to disclose sensitive information or execute arbitrary code. (CVE-2016-2008)

Solution

Upgrade to HP Data Protector 7.03 build 108 (7.03_108) / 8.15 / 9.06 or later per the vendor advisory.

See Also

http://www.nessus.org/u?b20bcde7

http://www.nessus.org/u?4bbf45ac

https://www.zerodayinitiative.com/advisories/ZDI-16-245/

https://www.zerodayinitiative.com/advisories/ZDI-16-246/

https://www.zerodayinitiative.com/advisories/ZDI-16-247/

Plugin Details

Severity: Critical

ID: 90796

File Name: hp_data_protector_hpsbgn03580.nasl

Version: 1.14

Type: combined

Family: Misc.

Published: 4/29/2016

Updated: 2/25/2019

Dependencies: os_fingerprint.nasl, ssh_get_info.nasl, hp_data_protector_installed.nasl, hp_data_protector_installed_local.nasl

Risk Information

CVSS Score Source: CVE-2016-2007

VPR

Risk Factor: High

Score: 7.4

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 8.3

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: E:F/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 9.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:hp:storage_data_protector

Required KB Items: Services/data_protector/version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 4/18/2016

Vulnerability Publication Date: 1/19/2015

Exploitable With

Core Impact

Metasploit (HP Data Protector Encrypted Communication Remote Command Execution)

Reference Information

CVE: CVE-2015-2808, CVE-2016-2004, CVE-2016-2005, CVE-2016-2006, CVE-2016-2007, CVE-2016-2008

BID: 73684, 87037, 87040, 87053, 87055, 87061

CERT: 267328

EDB-ID: 39858

HP: emr_na-c05085988, HPSBGN03580, SSRT102163, PSRT102293, PSRT102979, PSRT102980, PSRT102981, PSRT102956, PSRT102948

ZDI: ZDI-16-245, ZDI-16-246, ZDI-16-247