Core FTP Server < 1.2 Build 588 32-bit Unspecified Overflow Vulnerability

critical Nessus Plugin ID 90765
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The FTP server running on the remote host is affected by an unspecified overflow vulnerability.

Description

The 32-bit version of Core FTP Server running on the remote host is prior to 1.2 build 588. It is, therefore, affected by an overflow condition due to a failure to properly validate user-supplied input when using FTP, FTPS, or SSL. An unauthenticated, remote attacker can exploit this to impact the confidentiality, integrity, or availability of the system. No other details are provided. Note that the 64-bit version is not affected.

Solution

Upgrade to Core FTP version 1.2 build 588 (32-bit) or later.

See Also

http://www.nessus.org/u?006bcb64

Plugin Details

Severity: Critical

ID: 90765

File Name: coreftp_server_1_2_588.nasl

Version: 1.4

Type: remote

Family: FTP

Published: 4/27/2016

Updated: 8/8/2018

Dependencies: coreftp_server_detect.nbin

Risk Information

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 7.4

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:coreftp:coreftp

Required KB Items: installed_sw/Core FTP Server

Patch Publication Date: 4/7/2016

Vulnerability Publication Date: 4/7/2016