IBM WebSphere Application Server 7.0 < / 8.0 < / 8.5 < OAuth Provider XSS

Low Nessus Plugin ID 90316


The remote web application server is affected by an XSS vulnerability.


The IBM WebSphere Application Server running on the remote host is version 7.0 prior to, 8.0 prior to, or 8.5 prior to It is, therefore, potentially affected by a reflected cross-site scripting (XSS) vulnerability due to a failure to properly validate output from the OAuth provider before returning it to users.
An authenticated, remote attacker can exploit this, via a specially crafted URL, to execute arbitrary script code in a user's browser session within the security context of the hosting website.


Apply IBM WebSphere Application Server version 7.0 Fix Pack 41 ( / 8.0 Fix Pack 12 ( / 8.5 Fix Pack 9 ( or later. Alternatively, apply the appropriate Interim Fixes as recommended in the vendor advisory.

See Also

Plugin Details

Severity: Low

ID: 90316

File Name: websphere_8_5_5_9.nasl

Version: $Revision: 1.2 $

Type: remote

Family: Web Servers

Published: 2016/04/04

Modified: 2016/05/02

Dependencies: 57034

Risk Information

Risk Factor: Low


Base Score: 3.5

Temporal Score: 2.9

Vector: CVSS2#AV:N/AC:M/Au:S/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/a:ibm:websphere_application_server

Required KB Items: www/WebSphere, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2016/01/19

Vulnerability Publication Date: 2016/01/19

Reference Information

CVE: CVE-2015-7417

BID: 81738

OSVDB: 133484