OpenSSH < 7.2 Untrusted X11 Forwarding Fallback Security Bypass

High Nessus Plugin ID 90022


The SSH server running on the remote host is affected by a security bypass vulnerability.


According to its banner, the version of OpenSSH running on the remote host is prior to 7.2. It is, therefore, affected by a security bypass vulnerability due to a flaw in ssh(1) that is triggered when it falls back from untrusted X11 forwarding to trusted forwarding when the SECURITY extension is disabled by the X server. This can result in untrusted X11 connections that can be exploited by a remote attacker.


Upgrade to OpenSSH version 7.2 or later.

See Also

Plugin Details

Severity: High

ID: 90022

File Name: openssh_72.nasl

Version: $Revision: 1.4 $

Type: remote

Family: Misc.

Published: 2016/03/18

Modified: 2018/02/20

Dependencies: 10267

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:openbsd:openssh

Required KB Items: Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/02/29

Vulnerability Publication Date: 2016/02/29

Reference Information

CVE: CVE-2016-1908

OSVDB: 135128