Adobe Acrobat < 11.0.15 / 15.006.30121 / 15.010.20060 Multiple Vulnerabilities (APSB16-09)

High Nessus Plugin ID 89830

Synopsis

The version of Adobe Acrobat installed on the remote Windows host is affected by multiple vulnerabilities.

Description

The version of Adobe Acrobat installed on the remote Windows host is prior to 11.0.15, 15.006.30121, or 15.010.20060. It is, therefore, affected by multiple vulnerabilities :

- A memory corruption issue exists due to the use of uninitialized memory when handling annotation gestures.
A remote attacker can exploit this, via a crafted PDF file, to corrupt memory, resulting in a denial of service or the execution of arbitrary code.
(CVE-2016-1007)

- A flaw exists related to searching and loading dynamic-link library (DLL) files due to using a search path that may contain directories which are not trusted or under the user's control. An attacker can exploit this, by injecting a malicious DLL into the path, to gain elevated privileges. (CVE-2016-1008)

- An array indexing error exists due to improper validation of user-supplied input. A remote attacker can exploit this, via a crafted PDF file, to corrupt memory, resulting in a denial of service or the execution of arbitrary code. (CVE-2016-1009)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Adobe Acrobat version 11.0.15 / 15.006.30121 / 15.010.20060 or later.

See Also

https://helpx.adobe.com/security/products/reader/apsb16-09.html

Plugin Details

Severity: High

ID: 89830

File Name: adobe_acrobat_apsb16-09.nasl

Version: 1.9

Type: local

Agent: windows

Family: Windows

Published: 2016/03/10

Updated: 2018/06/29

Dependencies: 40797

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:acrobat

Required KB Items: SMB/Registry/Enumerated, installed_sw/Adobe Acrobat

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/03/08

Vulnerability Publication Date: 2016/03/08

Reference Information

CVE: CVE-2016-1007, CVE-2016-1008, CVE-2016-1009

BID: 84215, 84216