VMware ESX Multiple Vulnerabilities (VMSA-2010-0015) (remote check)

Critical Nessus Plugin ID 89742

Synopsis

The remote VMware ESX host is missing a security-related patch.

Description

The remote VMware ESX host is missing a security-related patch. It is, therefore, affected by multiple vulnerabilities, including remote code execution vulnerabilities, in several third-party components and libraries :

- Berkeley DB NSS module
- cURL / libcURL
- GnuTLS
- Network Security Services (NSS) Library
- OpenLDAP
- OpenSSL
- OpenSSL Kerberos
- sudo

Solution

Apply the appropriate patch as referenced in the vendor advisory that pertains to ESX version 4.0 / 4.1.

See Also

http://lists.vmware.com/pipermail/security-announce/2010/000110.html

Plugin Details

Severity: Critical

ID: 89742

File Name: vmware_VMSA-2010-0015_remote.nasl

Version: 1.4

Type: remote

Published: 2016/03/08

Updated: 2018/08/06

Dependencies: 57396

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/o:vmware:esx

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/11/16

Vulnerability Publication Date: 2010/09/03

Reference Information

CVE: CVE-2009-2409, CVE-2009-3245, CVE-2009-3555, CVE-2009-3767, CVE-2010-0433, CVE-2010-0734, CVE-2010-0826, CVE-2010-1646

BID: 29330, 36844, 36935, 38162, 38533, 38562, 39132, 40538

VMSA: 2010-0015

CWE: 20, 310