Jenkins < 1.642.2 / 1.650 Java Object Deserialization RCE

Critical Nessus Plugin ID 89725


The remote web server is affected by a remote code execution vulnerability.


The remote web server hosts a version of Jenkins or Jenkins Enterprise that is prior to 1.642.2 or 1.650. It is, therefore, affected by a Java deserialization vulnerability. An unauthenticated, remote attacker can exploit this, by deserializing specific java.rmi and sun.rmi objects, to start a JRMP listener on the server. The JRMP listener can then be exploited over RMI using objects in the Groovy or Apache Commons Collections libraries, resulting in the execution of arbitrary code.

Note that the server is reportedly affected by a number of other vulnerabilities per the Jenkins Security advisory; however, Nessus has not tested for these.


Upgrade to Jenkins version 1.642.2 / 1.650 or later. Alternatively, disable the CLI port per the vendor advisory.

See Also

Plugin Details

Severity: Critical

ID: 89725

File Name: jenkins_security232.nasl

Version: $Revision: 1.6 $

Type: remote

Family: General

Published: 2016/03/07

Modified: 2016/07/28

Dependencies: 65054

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 8.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/a:cloudbees:jenkins

Required KB Items: www/Jenkins

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2016/02/24

Vulnerability Publication Date: 2016/02/03

Exploitable With


Core Impact

Reference Information

CVE: CVE-2016-0788

BID: 83715

OSVDB: 135041