Debian DSA-3504-1 : bsh - security update

Medium Nessus Plugin ID 89694

Synopsis

The remote Debian host is missing a security-related update.

Description

Alvaro Munoz and Christian Schneider discovered that BeanShell, an embeddable Java source interpreter, could be leveraged to execute arbitrary commands: applications including BeanShell in their classpath are vulnerable to this flaw if they deserialize data from an untrusted source.

Solution

Upgrade the bsh packages.

For the oldstable distribution (wheezy), this problem has been fixed in version 2.0b4-12+deb7u1.

For the stable distribution (jessie), this problem has been fixed in version 2.0b4-15+deb8u1.

See Also

https://packages.debian.org/source/wheezy/bsh

https://packages.debian.org/source/jessie/bsh

https://www.debian.org/security/2016/dsa-3504

Plugin Details

Severity: Medium

ID: 89694

File Name: debian_DSA-3504.nasl

Version: 2.5

Type: local

Agent: unix

Published: 2016/03/07

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 8.1

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:bsh, cpe:/o:debian:debian_linux:7.0, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2016/03/04

Reference Information

CVE: CVE-2016-2510

DSA: 3504