Palo Alto Networks PAN-OS Multiple Vulnerabilities (PAN-SA-2016-0003, PAN-SA-2016-0005)
Critical Nessus Plugin ID 89688
SynopsisThe remote host is affected by multiple vulnerabilities.
DescriptionThe Palo Alto Networks PAN-OS running on the remote host is version 5.0.x prior to 5.0.18, 6.0.x prior to 6.0.13, 6.1.x prior to 6.1.10, or 7.0.x prior to 7.0.5. It is, therefore, affected by the following vulnerabilities:
- An overflow condition exists in the GlobalProtect web portal due to improper validation of user-supplied input when handling SSL VPN requests. An unauthenticated, remote attacker can exploit this, via a crafted request, to cause a denial of service or to execute arbitrary code.
- A flaw exists in the web-based management API due to improper parsing of user-supplied input to certain API calls. An unauthenticated, remote attacker can exploit this to inject and execute arbitrary OS commands.
SolutionUpgrade to Palo Alto Networks PAN-OS version 5.0.18 / 6.0.13 / 6.1.10 / 7.0.5 or later.