VMware ESX Third-Party Libraries Multiple Vulnerabilities (VMSA-2011-0001) (remote check)

High Nessus Plugin ID 89673


The remote VMware ESX host is missing a security-related patch.


The remote VMware ESX host is missing a security-related patch. It is, therefore, affected by multiple vulnerabilities, including arbitrary code execution vulnerabilities, in several third-party components and libraries :

- glibc
- glibc-common
- nscd
- openldap
- sudo


Apply the appropriate patch according to the vendor advisory that pertains to ESX version 4.0 / 4.1.

See Also



Plugin Details

Severity: High

ID: 89673

File Name: vmware_VMSA-2011-0001_remote.nasl

Version: $Revision: 1.3 $

Type: remote

Family: Misc.

Published: 2016/03/04

Modified: 2018/02/12

Dependencies: 57396

Risk Information

Risk Factor: High


Base Score: 7.2

Temporal Score: 6.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/o:vmware:esx

Required KB Items: Host/VMware/version, Host/VMware/release

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2011/01/04

Vulnerability Publication Date: 2010/07/09

Exploitable With


Core Impact

Metasploit (glibc LD_AUDIT Arbitrary DSO Load Privilege Escalation)

Reference Information

CVE: CVE-2010-0211, CVE-2010-0212, CVE-2010-2956, CVE-2010-3847, CVE-2010-3856

BID: 41770, 43019, 44154, 44347

OSVDB: 66469, 66470, 67842, 68721, 68920

VMSA: 2011-0001