VMware ESX Service Console Multiple Vulnerabilities (VMSA-2012-0008) (remote check)

Critical Nessus Plugin ID 89109


The remote VMware ESX host is missing a security-related patch.


The remote VMware ESX host is missing a security-related patch. It is, therefore, affected by multiple vulnerabilities, including remote code execution vulnerabilities, in the following components :

- COS kernel
- libxml2


Apply the appropriate patch according to the vendor advisory.

See Also


Plugin Details

Severity: Critical

ID: 89109

File Name: vmware_VMSA-2012-0008_remote.nasl

Version: $Revision: 1.2 $

Type: remote

Family: Misc.

Published: 2016/03/03

Modified: 2016/03/04

Dependencies: 57396

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/o:vmware:esx

Required KB Items: Host/VMware/version, Host/VMware/release

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/04/26

Vulnerability Publication Date: 2010/10/15

Reference Information

CVE: CVE-2010-4008, CVE-2011-0216, CVE-2011-1944, CVE-2011-2834, CVE-2011-3191, CVE-2011-3905, CVE-2011-3919, CVE-2011-4348, CVE-2012-0028

BID: 44779, 48056, 48832, 49295, 49658, 51084, 51300, 51363, 51947

OSVDB: 69205, 73248, 73994, 74910, 75560, 77707, 78148, 78303, 79098

VMSA: 2012-0008