Debian DLA-434-1 : gtk+2.0 security update

Medium Nessus Plugin ID 88995

Synopsis

The remote Debian host is missing a security update.

Description

Gustavo Grieco discovered different security issues in Gtk+2.0's gdk-pixbuf.

CVE-2015-4491

Heap overflow when processing BMP images which may allow to execute of arbitrary code via malformed images.

CVE-2015-7673

Heap overflow when processing TGA images which may allow execute arbitrary code or denial of service (process crash) via malformed images.

CVE-2015-7674

Integer overflow when processing GIF images which may allow to execute arbitrary code or denial of service (process crash) via malformed image.

For Debian 6 'Squeeze', these issues have been fixed in gtk+2.0 version 2.20.1-2+deb6u2. We recommend you to upgrade your gtk+2.0 packages.

Learn more about the Debian Long Term Support (LTS) Project and how to apply these updates at: https://wiki.debian.org/LTS/

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2016/02/msg00026.html

https://packages.debian.org/source/squeeze-lts/gtk+2.0

https://wiki.debian.org/LTS/

Plugin Details

Severity: Medium

ID: 88995

File Name: debian_DLA-434.nasl

Version: 2.5

Type: local

Agent: unix

Published: 2016/02/29

Updated: 2018/07/06

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:gtk2-engines-pixbuf, p-cpe:/a:debian:debian_linux:gtk2.0-examples, p-cpe:/a:debian:debian_linux:libgail-common, p-cpe:/a:debian:debian_linux:libgail-dbg, p-cpe:/a:debian:debian_linux:libgail-dev, p-cpe:/a:debian:debian_linux:libgail-doc, p-cpe:/a:debian:debian_linux:libgail18, p-cpe:/a:debian:debian_linux:libgtk2.0-0, p-cpe:/a:debian:debian_linux:libgtk2.0-0-dbg, p-cpe:/a:debian:debian_linux:libgtk2.0-0-udeb, p-cpe:/a:debian:debian_linux:libgtk2.0-bin, p-cpe:/a:debian:debian_linux:libgtk2.0-common, p-cpe:/a:debian:debian_linux:libgtk2.0-dev, p-cpe:/a:debian:debian_linux:libgtk2.0-doc, cpe:/o:debian:debian_linux:6.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/02/27

Reference Information

CVE: CVE-2015-4491, CVE-2015-7673, CVE-2015-7674