Nessus SQLite Multiple RCE

High Nessus Plugin ID 88964


An application running on the remote host is affected by multiple remote code execution vulnerabilities.


According to its self-reported version number, the version of Nessus running on the remote host is affected by multiple remote code execution vulnerabilities in the bundled version of SQLite due to heap-based buffer overflow conditions in the sqlite3VdbeExec() and resolve_backslashes() functions. A remote attacker can exploit these issues to cause a denial of service condition or the execution of arbitrary code.


Upgrade to Nessus version 5.2.11 / 6.3.7 or later.

See Also

Plugin Details

Severity: High

ID: 88964

File Name: nessus_sqlite_multiple.nasl

Version: $Revision: 1.6 $

Type: remote

Family: Misc.

Published: 2016/02/25

Modified: 2017/03/03

Dependencies: 10147

Risk Information

Risk Factor: High


Base Score: 9

Temporal Score: 7

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:ND


Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:sqlite:sqlite, cpe:/a:tenable:nessus

Required KB Items: installed_sw/nessus

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2015/05/26

Vulnerability Publication Date: 2015/05/26

Reference Information

CVE: CVE-2015-5895

OSVDB: 122105, 122106