BlackBerry Enterprise Service Multiple Vulnerabilities (BSRT-2016-001)

Medium Nessus Plugin ID 88881


The remote Windows host has an application installed that is affected by multiple vulnerabilities.


According to its version, the BlackBerry Enterprise Service (BES) install on the remote host is older than 12.4, it is, therefore, affected by the following vulnerabilities:

- A SQL injection vulnerability exists due to improper sanitization of user-supplied input to the 'ImageName' parameter in the com.rim.mdm.ui.server.ImageServlet servlet. A remote attacker can exploit this, by convincing a user to click a specially crafted link, to inject or manipulate SQL queries to the back-end database, resulting in the manipulation or disclosure or arbitrary data. (CVE-2016-1914)

- Multiple cross-site scripting vulnerabilities exist due to improper sanitization of user-supplied input to the 'locale' parameter in the index.jsp and loggedOut.jsp scripts. A remote attacker can exploit this, via a specially crafted request, to execute arbitrary script code in a user's browser session. (CVE-2016-1915)


Update to BlackBerry Enterprise Service version 12.4 or later.

See Also

Plugin Details

Severity: Medium

ID: 88881

File Name: blackberry_es_12_4.nasl

Version: $Revision: 1.2 $

Type: local

Agent: windows

Family: Windows

Published: 2016/02/22

Modified: 2016/04/28

Dependencies: 20949

Risk Information

Risk Factor: Medium


Base Score: 6

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/a:blackberry:blackberry_enterprise_service

Required KB Items: SMB/Registry/Enumerated, BlackBerry_ES/Product

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2016/01/29

Vulnerability Publication Date: 2016/02/15

Reference Information

CVE: CVE-2016-1914, CVE-2016-1915

OSVDB: 134674, 134675, 134676