Tenable SecurityCenter OpenSSL ASN.1 Signature Verification Routine DoS (TNS-2016-01)

Medium Nessus Plugin ID 88809


The remote application is affected by a denial of service vulnerability.


The SecurityCenter application installed on the remote host is affected by a denial of service vulnerability in the bundled OpenSSL library. The library is version 1.0.1 or later but prior to 1.0.1q. It is, therefore, affected by a NULL pointer dereference flaw in file rsa_ameth.c due to improper handling of ASN.1 signatures that are missing the PSS parameter. A remote attacker can exploit this to cause the signature verification routine to crash, resulting in a denial of service condition.


Upgrade to Tenable SecurityCenter version 5.2.0. Alternatively, apply the relevant patch referenced in the vendor advisory.

See Also





Plugin Details

Severity: Medium

ID: 88809

File Name: securitycenter_openssl_1_0_1q.nasl

Version: $Revision: 1.17 $

Type: local

Family: Misc.

Published: 2016/02/17

Modified: 2018/02/14

Dependencies: 71158

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:tenable:securitycenter

Required KB Items: Host/SecurityCenter/Version, Host/local_checks_enabled, Host/SecurityCenter/support/openssl/version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/12/16

Vulnerability Publication Date: 2015/12/03

Reference Information

CVE: CVE-2015-3194

BID: 78623

OSVDB: 131038