CentOS 7 : polkit (CESA-2016:0189)

Medium Nessus Plugin ID 88761

Synopsis

The remote CentOS host is missing one or more security updates.

Description

Updated polkit packages that fix one security issue are now available for Red Hat Enterprise Linux 7.

Red Hat Product Security has rated this update as having Moderate security impact. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available from the CVE link in the References section.

PolicyKit is a toolkit for defining and handling authorizations.

A denial of service flaw was found in how polkit handled authorization requests. A local, unprivileged user could send malicious requests to polkit, which could then cause the polkit daemon to corrupt its memory and crash. (CVE-2015-3256)

All polkit users should upgrade to these updated packages, which contain a backported patch to correct this issue. The system must be rebooted for this update to take effect.

Solution

Update the affected polkit packages.

See Also

http://www.nessus.org/u?39ad4435

Plugin Details

Severity: Medium

ID: 88761

File Name: centos_RHSA-2016-0189.nasl

Version: 2.6

Type: local

Agent: unix

Published: 2016/02/17

Updated: 2019/10/02

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.6

Temporal Score: 3.4

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:centos:centos:polkit, p-cpe:/a:centos:centos:polkit-devel, p-cpe:/a:centos:centos:polkit-docs, cpe:/o:centos:centos:7

Required KB Items: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/02/16

Vulnerability Publication Date: 2015/10/26

Reference Information

CVE: CVE-2015-3256

RHSA: 2016:0189