Firefox ESR < 38.6.1 Multiple Graphite 2 Library RCE

High Nessus Plugin ID 88753


The remote Windows host contains a web browser that is affected by multiple remote code execution vulnerabilities.


The version of Mozilla Firefox ESR installed on the remote Windows host is prior to 38.6.1. It is, therefore, affected by multiple remote code execution vulnerabilities in the Graphite 2 library :

- An overflow condition exists in the Context Item functionality due to improper validation of user-supplied input. An unauthenticated, remote attacker can exploit this, via a crafted Graphite smart font, to cause a heap-based buffer overflow, resulting in a denial of service or the execution of arbitrary code.

- An out-of-bounds write error exists in the setAttr() function that is triggered when handling maliciously crafted fonts. An unauthenticated, remote attacker can exploit this to execute arbitrary code. (CVE-2016-1969)


Upgrade to Mozilla Firefox ESR version 38.6.1 or later.

See Also

Plugin Details

Severity: High

ID: 88753

File Name: mozilla_firefox_38_6_1_esr.nasl

Version: $Revision: 1.9 $

Type: local

Agent: windows

Family: Windows

Published: 2016/02/16

Modified: 2016/05/03

Dependencies: 20862

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:U/RC:UC

Vulnerability Information

CPE: cpe:/a:mozilla:firefox_esr

Required KB Items: Mozilla/Firefox/Version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/02/11

Vulnerability Publication Date: 2016/02/05

Reference Information

CVE: CVE-2016-1523, CVE-2016-1969

BID: 82991

OSVDB: 134246, 135666

MFSA: 2016-14, 2016-38