Adobe Photoshop CC < 15.2.4 / 16.1.2 Multiple Memory Corruption Vulnerabilities (APSB16-03) (Mac OS X)

High Nessus Plugin ID 88721


The remote host has an application installed that is affected by multiple memory corruption vulnerabilities.


The version of Adobe Photoshop installed on the remote Mac OS X host is prior to 15.2.4 (2014.2.4) or 16.1.2 (2015.1.2). It is, therefore, affected by multiple unspecified memory corruption issues due to improper validation of user-supplied input. An unauthenticated, remote attacker can exploit these issues to execute arbitrary code.


Upgrade to Adobe Photoshop CC version 15.2.4 (2014.2.4) / 16.1.2 (2015.1.2) or later.

See Also

Plugin Details

Severity: High

ID: 88721

File Name: macosx_adobe_photoshop_apsb16-03.nasl

Version: $Revision: 1.9 $

Type: local

Agent: macosx

Published: 2016/02/12

Modified: 2017/04/15

Dependencies: 62220

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/a:adobe:photoshop, cpe:/a:adobe:photoshop_cc

Required KB Items: Host/local_checks_enabled, Host/MacOSX/Version, installed_sw/Adobe Photoshop

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2016/02/09

Vulnerability Publication Date: 2016/02/09

Reference Information

CVE: CVE-2016-0951, CVE-2016-0952, CVE-2016-0953

BID: 83114

OSVDB: 134281, 134282, 134283