FreeSWITCH < 1.4.26 / 1.6.x < 1.6.5 JSON Parser RCE

High Nessus Plugin ID 88696


The remote FreeSWITCH server is affected by a remote code execution vulnerability.


The remote FreeSWITCH server is prior to version 1.4.26 or 1.6.x prior to 1.6.5. It is, therefore, affected by a remote code execution vulnerability due to improper validation of user-supplied input to the parse_string() function in esl_json.c, switch_json.c, and ks_json.c. A remote attacker can exploit this, via a crafted JSON message, to cause a heap-based buffer overflow condition, resulting in a denial of service or the execution of arbitrary code.


Upgrade to FreeSWITCH version 1.4.26 / 1.6.5 or later.

See Also

Plugin Details

Severity: High

ID: 88696

File Name: freeswitch_fs8160.nasl

Version: $Revision: 1.3 $

Type: remote

Family: Misc.

Published: 2016/02/11

Modified: 2017/05/16

Dependencies: 88697

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:freeswitch:freeswitch

Required KB Items: Settings/ParanoidReport, sip/freeswitch/present

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/11/24

Vulnerability Publication Date: 2015/09/14

Reference Information

CVE: CVE-2015-7392, CVE-2015-8311

BID: 76976

OSVDB: 128211

TRA: TRA-2015-05