OpenSSL 1.0.2 < 1.0.2f Multiple Vulnerabilities (Logjam)

Medium Nessus Plugin ID 88530


The remote service is affected by multiple vulnerabilities.


According to its banner, the remote host is running a version of OpenSSL 1.0.2 prior to 1.0.2f. It is, therefore, affected by the following vulnerabilities :

- A cipher algorithm downgrade vulnerability exists due to a flaw that is triggered when handling cipher negotiation. A remote attacker can exploit this to negotiate SSLv2 ciphers and complete SSLv2 handshakes even if all SSLv2 ciphers have been disabled on the server. Note that this vulnerability only exists if the SSL_OP_NO_SSLv2 option has not been disabled.

- A man-in-the-middle vulnerability, known as Logjam, exists due to a flaw in the SSL/TLS protocol. A remote attacker can exploit this flaw to downgrade connections using ephemeral Diffie-Hellman key exchange to 512-bit export-grade cryptography. (CVE-2015-4000)

- An information disclosure vulnerability exists due to a flaw in the DH_check_pub_key() function that is triggered when generating DH parameters based on unsafe primes. A remote attacker can exploit this, via multiple handshakes, to disclose the private DH exponent.


Upgrade to OpenSSL version 1.0.2f or later.

See Also

Plugin Details

Severity: Medium

ID: 88530

File Name: openssl_1_0_2f.nasl

Version: $Revision: 1.7 $

Type: remote

Family: Web Servers

Published: 2016/02/02

Modified: 2016/04/26

Dependencies: 57323

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:TF/RC:ND

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: openssl/port

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2016/01/28

Vulnerability Publication Date: 2016/01/28

Reference Information

CVE: CVE-2015-3197, CVE-2015-4000, CVE-2016-0701

BID: 74733

OSVDB: 122331, 133714, 133715

CERT: 257823