Debian DLA-402-1 : tiff security update

Medium Nessus Plugin ID 88387

Synopsis

The remote Debian host is missing a security update.

Description

Two security flaws have been found and solved in libtiff, library that provides support for handling Tag Image File Format (TIFF). These flaws concern out of bounds reads in the TIFFRGBAImage interface, when parsing unsupported values related to LogLUV and CIELab. CVE-2015-8665 was reported by limingxing and CVE-2015-8683 by zzf of Alibaba.

For Debian 6 'Squeeze', these issues have been fixed in tiff version 3.9.4-5+squeeze13. We recommend you to upgrade your tiff packages.

Learn more about the Debian Long Term Support (LTS) Project and how to apply these updates at: https://wiki.debian.org/LTS/

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2016/01/msg00027.html

https://packages.debian.org/source/squeeze-lts/tiff

https://wiki.debian.org/LTS/

Plugin Details

Severity: Medium

ID: 88387

File Name: debian_DLA-402.nasl

Version: 2.10

Type: local

Agent: unix

Published: 2016/01/27

Updated: 2018/07/09

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 5.5

Temporal Score: 4.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libtiff-doc, p-cpe:/a:debian:debian_linux:libtiff-opengl, p-cpe:/a:debian:debian_linux:libtiff-tools, p-cpe:/a:debian:debian_linux:libtiff4, p-cpe:/a:debian:debian_linux:libtiff4-dev, p-cpe:/a:debian:debian_linux:libtiffxx0c2, cpe:/o:debian:debian_linux:6.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/01/26

Reference Information

CVE: CVE-2015-8665, CVE-2015-8683