Debian DSA-3447-1 : tomcat7 - security update

Medium Nessus Plugin ID 87979

Synopsis

The remote Debian host is missing a security-related update.

Description

It was discovered that malicious web applications could use the Expression Language to bypass protections of a Security Manager as expressions were evaluated within a privileged code section.

Solution

Upgrade the tomcat7 packages.

For the oldstable distribution (wheezy), this problem has been fixed in version 7.0.28-4+deb7u3. This update also provides fixes for CVE-2013-4444, CVE-2014-0075, CVE-2014-0099, CVE-2014-0227 and CVE-2014-0230, which were all fixed for the stable distribution (jessie) already.

For the stable distribution (jessie), this problem has been fixed in version 7.0.56-3+deb8u1.

See Also

https://security-tracker.debian.org/tracker/CVE-2013-4444

https://security-tracker.debian.org/tracker/CVE-2014-0075

https://security-tracker.debian.org/tracker/CVE-2014-0099

https://security-tracker.debian.org/tracker/CVE-2014-0227

https://security-tracker.debian.org/tracker/CVE-2014-0230

https://packages.debian.org/source/wheezy/tomcat7

https://packages.debian.org/source/jessie/tomcat7

https://www.debian.org/security/2016/dsa-3447

Plugin Details

Severity: Medium

ID: 87979

File Name: debian_DSA-3447.nasl

Version: 2.7

Type: local

Agent: unix

Published: 2016/01/19

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:tomcat7, cpe:/o:debian:debian_linux:7.0, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/01/17

Reference Information

CVE: CVE-2014-7810

DSA: 3447