GLSA-201512-11 : Firebird: Buffer Overflow

Medium Nessus Plugin ID 87711


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201512-11 (Firebird: Buffer Overflow)

The vulnerability is caused due to an error when processing requests from remote clients.
Impact :

A remote attacker could possibly execute arbitrary code with the privileges of the process, or cause a Denial of Service condition.
Workaround :

There is no known workaround at this time.


All Firebird users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-db/firebird-' NOTE: Firebird package was moved to the testing branch (unstable) of Gentoo. There is currently no stable version of Firebird, and there will be no further GLSAs for this package.

See Also

Plugin Details

Severity: Medium

ID: 87711

File Name: gentoo_GLSA-201512-11.nasl

Version: $Revision: 2.1 $

Type: local

Published: 2016/01/04

Modified: 2016/01/04

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:firebird, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2015/12/30

Exploitable With

Core Impact

Metasploit (Firebird Relational Database CNCT Group Number Buffer Overflow)

Reference Information

CVE: CVE-2013-2492

GLSA: 201512-11