GLSA-201512-09 : encfs: Multiple vulnerabilities

Medium Nessus Plugin ID 87709


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201512-09 (encfs: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in encfs. Please review the CVE identifiers referenced below for details.
Impact :

A local attacker can utilize a possible buffer overflow in the encodeName method of StreamNameIO and BlockNameIO to execute arbitrary code or cause a Denial of Service. Also multiple weak cryptographics practices have been found in encfs.
Workaround :

There is no known workaround at this time.


All encfs users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=sys-fs/encfs-1.7.5'

See Also

Plugin Details

Severity: Medium

ID: 87709

File Name: gentoo_GLSA-201512-09.nasl

Version: $Revision: 2.3 $

Type: local

Published: 2016/01/04

Modified: 2018/01/26

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N


Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:encfs, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2015/12/30

Reference Information

CVE: CVE-2014-3462

GLSA: 201512-09