Debian DLA-376-1 : mono security update

medium Nessus Plugin ID 87682
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Debian host is missing a security update.

Description

Mono's string-to-double parser may crash, on specially crafted input.
This could theoretically lead to arbitrary code execution.

This issue has been fixed in Debian 6 Squeeze with the version 2.6.7-5.1+deb6u2 of mono. We recommend that you upgrade your mono packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2015/12/msg00018.html

https://packages.debian.org/source/squeeze-lts/mono

Plugin Details

Severity: Medium

ID: 87682

File Name: debian_DLA-376.nasl

Version: 2.8

Type: local

Agent: unix

Published: 1/4/2016

Updated: 1/11/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 6.6

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.3

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libmono-accessibility1.0-cil, p-cpe:/a:debian:debian_linux:libmono-accessibility2.0-cil, p-cpe:/a:debian:debian_linux:libmono-bytefx0.7.6.1-cil, p-cpe:/a:debian:debian_linux:libmono-bytefx0.7.6.2-cil, p-cpe:/a:debian:debian_linux:libmono-c5-1.1-cil, p-cpe:/a:debian:debian_linux:libmono-cairo1.0-cil, p-cpe:/a:debian:debian_linux:libmono-cairo2.0-cil, p-cpe:/a:debian:debian_linux:libmono-cecil-private-cil, p-cpe:/a:debian:debian_linux:libmono-cil-dev, p-cpe:/a:debian:debian_linux:libmono-corlib1.0-cil, p-cpe:/a:debian:debian_linux:libmono-corlib2.0-cil, p-cpe:/a:debian:debian_linux:libmono-cscompmgd7.0-cil, p-cpe:/a:debian:debian_linux:libmono-cscompmgd8.0-cil, p-cpe:/a:debian:debian_linux:libmono-data-tds1.0-cil, p-cpe:/a:debian:debian_linux:libmono-data-tds2.0-cil, p-cpe:/a:debian:debian_linux:libmono-data1.0-cil, p-cpe:/a:debian:debian_linux:libmono-data2.0-cil, p-cpe:/a:debian:debian_linux:libmono-db2-1.0-cil, p-cpe:/a:debian:debian_linux:libmono-debugger-soft0.0-cil, p-cpe:/a:debian:debian_linux:libmono-dev, p-cpe:/a:debian:debian_linux:libmono-firebirdsql1.7-cil, p-cpe:/a:debian:debian_linux:libmono-getoptions1.0-cil, p-cpe:/a:debian:debian_linux:libmono-getoptions2.0-cil, p-cpe:/a:debian:debian_linux:libmono-i18n-west1.0-cil, p-cpe:/a:debian:debian_linux:libmono-i18n-west2.0-cil, p-cpe:/a:debian:debian_linux:libmono-i18n1.0-cil, p-cpe:/a:debian:debian_linux:libmono-i18n2.0-cil, p-cpe:/a:debian:debian_linux:libmono-ldap1.0-cil, p-cpe:/a:debian:debian_linux:libmono-ldap2.0-cil, p-cpe:/a:debian:debian_linux:libmono-management2.0-cil, p-cpe:/a:debian:debian_linux:libmono-messaging-rabbitmq2.0-cil, p-cpe:/a:debian:debian_linux:libmono-messaging2.0-cil, p-cpe:/a:debian:debian_linux:libmono-microsoft-build2.0-cil, p-cpe:/a:debian:debian_linux:libmono-microsoft7.0-cil, p-cpe:/a:debian:debian_linux:libmono-microsoft8.0-cil, p-cpe:/a:debian:debian_linux:libmono-npgsql1.0-cil, p-cpe:/a:debian:debian_linux:libmono-npgsql2.0-cil, p-cpe:/a:debian:debian_linux:libmono-oracle1.0-cil, p-cpe:/a:debian:debian_linux:libmono-oracle2.0-cil, p-cpe:/a:debian:debian_linux:libmono-peapi1.0-cil, p-cpe:/a:debian:debian_linux:libmono-peapi2.0-cil, p-cpe:/a:debian:debian_linux:libmono-posix1.0-cil, p-cpe:/a:debian:debian_linux:libmono-posix2.0-cil, p-cpe:/a:debian:debian_linux:libmono-profiler, p-cpe:/a:debian:debian_linux:libmono-rabbitmq2.0-cil, p-cpe:/a:debian:debian_linux:libmono-relaxng1.0-cil, p-cpe:/a:debian:debian_linux:libmono-relaxng2.0-cil, p-cpe:/a:debian:debian_linux:libmono-security1.0-cil, p-cpe:/a:debian:debian_linux:libmono-security2.0-cil, p-cpe:/a:debian:debian_linux:libmono-sharpzip0.6-cil, p-cpe:/a:debian:debian_linux:libmono-sharpzip0.84-cil, p-cpe:/a:debian:debian_linux:libmono-sharpzip2.6-cil, p-cpe:/a:debian:debian_linux:libmono-sharpzip2.84-cil, p-cpe:/a:debian:debian_linux:libmono-simd2.0-cil, p-cpe:/a:debian:debian_linux:libmono-sqlite1.0-cil, p-cpe:/a:debian:debian_linux:libmono-sqlite2.0-cil, p-cpe:/a:debian:debian_linux:libmono-system-data-linq2.0-cil, p-cpe:/a:debian:debian_linux:libmono-system-data1.0-cil, p-cpe:/a:debian:debian_linux:libmono-system-data2.0-cil, p-cpe:/a:debian:debian_linux:libmono-system-ldap1.0-cil, p-cpe:/a:debian:debian_linux:libmono-system-ldap2.0-cil, p-cpe:/a:debian:debian_linux:libmono-system-messaging1.0-cil, p-cpe:/a:debian:debian_linux:libmono-system-messaging2.0-cil, p-cpe:/a:debian:debian_linux:libmono-system-runtime1.0-cil, p-cpe:/a:debian:debian_linux:libmono-system-runtime2.0-cil, p-cpe:/a:debian:debian_linux:libmono-system-web-mvc1.0-cil, p-cpe:/a:debian:debian_linux:libmono-system-web-mvc2.0-cil, p-cpe:/a:debian:debian_linux:libmono-system-web1.0-cil, p-cpe:/a:debian:debian_linux:libmono-system-web2.0-cil, p-cpe:/a:debian:debian_linux:libmono-system1.0-cil, p-cpe:/a:debian:debian_linux:libmono-system2.0-cil, p-cpe:/a:debian:debian_linux:libmono-tasklets2.0-cil, p-cpe:/a:debian:debian_linux:libmono-wcf3.0-cil, p-cpe:/a:debian:debian_linux:libmono-webbrowser0.5-cil, p-cpe:/a:debian:debian_linux:libmono-windowsbase3.0-cil, p-cpe:/a:debian:debian_linux:libmono-winforms1.0-cil, p-cpe:/a:debian:debian_linux:libmono-winforms2.0-cil, p-cpe:/a:debian:debian_linux:libmono0, p-cpe:/a:debian:debian_linux:libmono0-dbg, p-cpe:/a:debian:debian_linux:libmono1.0-cil, p-cpe:/a:debian:debian_linux:libmono2.0-cil, p-cpe:/a:debian:debian_linux:mono-1.0-devel, p-cpe:/a:debian:debian_linux:mono-1.0-gac, p-cpe:/a:debian:debian_linux:mono-1.0-service, p-cpe:/a:debian:debian_linux:mono-2.0-devel, p-cpe:/a:debian:debian_linux:mono-2.0-gac, p-cpe:/a:debian:debian_linux:mono-2.0-service, p-cpe:/a:debian:debian_linux:mono-complete, p-cpe:/a:debian:debian_linux:mono-csharp-shell, p-cpe:/a:debian:debian_linux:mono-dbg, p-cpe:/a:debian:debian_linux:mono-devel, p-cpe:/a:debian:debian_linux:mono-gac, p-cpe:/a:debian:debian_linux:mono-gmcs, p-cpe:/a:debian:debian_linux:mono-jay, p-cpe:/a:debian:debian_linux:mono-mcs, p-cpe:/a:debian:debian_linux:mono-mjs, p-cpe:/a:debian:debian_linux:mono-runtime, p-cpe:/a:debian:debian_linux:mono-runtime-dbg, p-cpe:/a:debian:debian_linux:mono-utils, p-cpe:/a:debian:debian_linux:mono-xbuild, p-cpe:/a:debian:debian_linux:monodoc-base, p-cpe:/a:debian:debian_linux:monodoc-manual, p-cpe:/a:debian:debian_linux:prj2make-sharp, cpe:/o:debian:debian_linux:6.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 12/30/2015

Reference Information

CVE: CVE-2009-0689

BID: 35510, 36565, 36851, 37078, 37080, 37687, 37688

CWE: 119