Debian DSA-3429-1 : foomatic-filters - security update

High Nessus Plugin ID 87541

Synopsis

The remote Debian host is missing a security-related update.

Description

Michal Kowalczyk and Adam Chester discovered that missing input sanitising in the foomatic-rip print filter might result in the execution of arbitrary commands.

Solution

Upgrade the foomatic-filters packages.

For the oldstable distribution (wheezy), these problems have been fixed in version 4.0.17-1+deb7u1.

For the stable distribution (jessie), these problems have been fixed in version 4.0.17-5+deb8u1.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=806886

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=807993

https://packages.debian.org/source/wheezy/foomatic-filters

https://packages.debian.org/source/jessie/foomatic-filters

https://www.debian.org/security/2015/dsa-3429

Plugin Details

Severity: High

ID: 87541

File Name: debian_DSA-3429.nasl

Version: 2.7

Type: local

Agent: unix

Published: 2015/12/22

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 7.3

Temporal Score: 6.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:foomatic-filters, cpe:/o:debian:debian_linux:7.0, cpe:/o:debian:debian_linux:8.0

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/12/21

Reference Information

CVE: CVE-2015-8327, CVE-2015-8560

DSA: 3429