GLSA-201512-02 : IPython: User-assisted execution of arbitrary code

Medium Nessus Plugin ID 87485


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201512-02 (IPython: User-assisted execution of arbitrary code)

IPython does not properly check the MIME type of a file.
Impact :

A remote attacker could entice a user to open a specially crafted text file using IPython, possibly resulting in execution of arbitrary JavaScript with the privileges of the process.
Workaround :

There is no known workaround at this time.


All IPython users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-python/ipython-3.2.1-r1'

See Also

Plugin Details

Severity: Medium

ID: 87485

File Name: gentoo_GLSA-201512-02.nasl

Version: $Revision: 2.1 $

Type: local

Published: 2015/12/18

Modified: 2015/12/18

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:ipython, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2015/12/17

Reference Information

CVE: CVE-2015-7337

GLSA: 201512-02