NVIDIA Graphics Driver 340.x < 341.92 / 352.x < 354.35 / 358.x < 358.87 Multiple Vulnerabilities

High Nessus Plugin ID 87412


The remote Windows host is affected by multiple vulnerabilities.


The version of the NVIDIA graphics driver installed on the remote Windows host is 340.x prior to 341.92, 352.x prior to 354.35, or 358.x prior to 358.87. It is, therefore, affected by multiple vulnerabilities :

- A privilege escalation vulnerability exists in the Stereoscopic 3D Driver Service due to improper restriction of access to the 'stereosvrpipe' named pipe.
An adjacent attacker can exploit this to execute arbitrary command line arguments, resulting in an escalation of privileges. (CVE-2015-7865)

- A privilege escalation vulnerability exists due to an unquoted Windows search path issue in the Smart Maximize Helper (nvSmartMaxApp.exe). A local attacker can exploit this to escalate privileges. (CVE-2015-7866)

- Multiple privilege escalation vulnerabilities exist in the NVAPI support layer due to multiple unspecified integer overflow conditions in the underlying kernel mode driver. A local attacker can exploit these issues to gain access to uninitialized or out-of-bounds memory, resulting in an escalation of privileges.
(CVE-2015-7869, CVE-2015-8328)


Upgrade to video driver version 341.92 / 354.35 / 358.87 or later.

See Also




Plugin Details

Severity: High

ID: 87412

File Name: nvidia_win_cve_2015_8328.nasl

Version: $Revision: 1.8 $

Type: local

Agent: windows

Family: Windows

Published: 2015/12/16

Modified: 2016/04/28

Dependencies: 72482

Risk Information

Risk Factor: High


Base Score: 7.7

Temporal Score: 6.4

Vector: CVSS2#AV:A/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/a:nvidia:gpu_driver

Required KB Items: WMI/DisplayDrivers/NVIDIA, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2015/11/13

Vulnerability Publication Date: 2015/11/13

Exploitable With

Core Impact

Reference Information

CVE: CVE-2015-7865, CVE-2015-7866, CVE-2015-7869, CVE-2015-8328

BID: 83873

OSVDB: 130455, 130456, 130457, 130643

EDB-ID: 38792