Citrix XenServer Multiple memory_exchange() Hypercall Error Handling DoS (CTX203451)

Medium Nessus Plugin ID 87373


The remote host is affected by multiple denial of service vulnerabilities.


The version of Citrix XenServer running on the remote host is affected by multiple denial of service vulnerabilities due to multiple flaws in the memory_exchange() function in memory.c that are triggered when handling hypercall XENMEM_exchange errors. A local attacker within a guest can exploit these flaws to cause a deadlock, resulting in a denial of service condition.


Apply the relevant hotfix referenced in the vendor advisory.

See Also

Plugin Details

Severity: Medium

ID: 87373

File Name: citrix_xenserver_CTX203451.nasl

Version: $Revision: 1.4 $

Type: local

Family: Misc.

Published: 2015/12/15

Modified: 2017/02/08

Dependencies: 76770

Risk Information

Risk Factor: Medium


Base Score: 5.5

Temporal Score: 4.1

Vector: CVSS2#AV:A/AC:L/Au:S/C:N/I:N/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 6.2

Vector: CVSS:3.0/AV:A/AC:L/PR:H/UI:N/S:C/C:N/I:N/A:H

Vulnerability Information

CPE: cpe:/a:citrix:xenserver

Required KB Items: Host/XenServer/version, Host/local_checks_enabled

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/12/08

Vulnerability Publication Date: 2015/12/08

Reference Information

CVE: CVE-2015-8339, CVE-2015-8340

BID: 79038

OSVDB: 131284, 131285