Mac OS X : Apple Safari < 9.0.2 Multiple RCE

High Nessus Plugin ID 87370


The remote host has a web browser installed that is affected by multiple remote code execution vulnerabilities.


The version of Apple Safari installed on the remote host is prior to 9.0.2. It is, therefore, affected by multiple memory corruption issues in WebKit due to improper memory handling. An unauthenticated, remote attacker can exploit these, via a crafted website, to execute arbitrary code or possibly cause a denial of service.


Upgrade to Apple Safari version 9.0.2 or later.

See Also

Plugin Details

Severity: High

ID: 87370

File Name: macosx_Safari9_0_2.nasl

Version: $Revision: 1.2 $

Type: local

Agent: macosx

Published: 2015/12/15

Modified: 2016/04/28

Dependencies: 31604

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.5

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:ND/RC:UR

Vulnerability Information

CPE: cpe:/a:apple:safari

Required KB Items: Host/local_checks_enabled, Host/MacOSX/Version, MacOSX/Safari/Installed

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/12/08

Vulnerability Publication Date: 2015/12/08

Reference Information

CVE: CVE-2015-7048, CVE-2015-7095, CVE-2015-7096, CVE-2015-7097, CVE-2015-7098, CVE-2015-7099, CVE-2015-7100, CVE-2015-7101, CVE-2015-7102, CVE-2015-7103, CVE-2015-7104, CVE-2015-7050

BID: 78720, 78722, 78726

OSVDB: 131370, 131371, 131372, 131373, 131374, 131375, 131376, 131377, 131378, 131379, 131380, 131440

APPLE-SA: APPLE-SA-2015-12-08-5