MS15-131: Security Update for Microsoft Office to Address Remote Code Execution (3116111) (Mac OS X)

High Nessus Plugin ID 87329


An application installed on the remote Mac OS X host is affected by multiple remote code execution vulnerabilities.


The version of Microsoft Office installed on the remote Mac OS X host is affected by multiple memory corruption issues due to improper handling of objects in memory. A remote attacker can exploit these issues by convincing a user to open a specially crafted file in an affected version of Office, resulting in the execution of arbitrary code in the context of the current user.


Microsoft has released patches for Office for Mac 2011 and for Office 2016 for Mac.

See Also

Plugin Details

Severity: High

ID: 87329

File Name: macosx_ms15-131_office.nasl

Version: $Revision: 1.10 $

Type: local

Agent: macosx

Published: 2015/12/11

Modified: 2017/08/30

Dependencies: 86383

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/a:microsoft:office:2011:mac, cpe:/a:microsoft:office:2016:mac, cpe:/a:microsoft:excel_for_mac:2011, cpe:/a:microsoft:excel_for_mac:2016

Required KB Items: Host/MacOSX/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2015/12/11

Vulnerability Publication Date: 2015/12/08

Reference Information

CVE: CVE-2015-6040, CVE-2015-6122

BID: 78543, 78547

OSVDB: 131335, 131337

MSFT: MS15-131

IAVA: 2015-A-0300

MSKB: 3119517, 3119518