OpenSSL 0.9.8 < 0.9.8zh X509_ATTRIBUTE Memory Leak DoS

medium Nessus Plugin ID 87219
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host is affected by a denial of service vulnerability.

Description

According to its banner, the remote host is running a version of OpenSSL 0.9.8 prior to 0.9.8zh. It is, therefore, affected by a flaw in the ASN1_TFLG_COMBINE implementation in file tasn_dec.c related to handling malformed X509_ATTRIBUTE structures. A remote attacker can exploit this to cause a memory leak by triggering a decoding failure in a PKCS#7 or CMS application, resulting in a denial of service.

Solution

Upgrade to OpenSSL version 0.9.8zh or later.

See Also

https://www.openssl.org/news/secadv/20151203.txt

Plugin Details

Severity: Medium

ID: 87219

File Name: openssl_0_9_8zh.nasl

Version: 1.15

Type: remote

Family: Web Servers

Published: 12/7/2015

Updated: 11/22/2019

Dependencies: openssl_version.nasl

Risk Information

CVSS Score Source: CVE-2015-3195

VPR

Risk Factor: Low

Score: 2.2

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: openssl/port

Exploit Ease: No known exploits are available

Patch Publication Date: 12/3/2015

Vulnerability Publication Date: 12/3/2015

Reference Information

CVE: CVE-2015-3195

BID: 78626