HP LoadRunner 11.52 / 12.00 / 12.01 / 12.02 / 12.50 Virtual Table Server RCE

Critical Nessus Plugin ID 87211


The remote Windows host has an application installed that is affected by a remote code execution vulnerability.


The version of HP LoadRunner installed on the remote host is 11.52, 12.00, 12.01, 12.02, or 12.50. It is, therefore, affected by a remote code execution vulnerability in the Virtual Table Server (VTS). An unauthenticated, remote attacker can exploit this, via a malicious connection string or SQL command, to execute arbitrary code.


Delete the web\admin\adoUtility.js file.

See Also




Plugin Details

Severity: Critical

ID: 87211

File Name: hp_loadrunner_vts_rce.nasl

Version: $Revision: 1.5 $

Type: local

Agent: windows

Family: Windows

Published: 2015/12/05

Modified: 2016/06/13

Dependencies: 59717

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 8.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/a:hp:loadrunner

Required KB Items: SMB/Registry/Enumerated, installed_sw/HP LoadRunner

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2015/11/24

Vulnerability Publication Date: 2015/11/24

Reference Information

CVE: CVE-2015-6857

BID: 77946

OSVDB: 130684

HP: HPSBGN03523, emr_na-c04900820