Google Chrome < 47.0.2526.73 Multiple Vulnerabilities (Mac OS X)

Critical Nessus Plugin ID 87207

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 6.7

Synopsis

The remote Mac OS X host contains a web browser that is affected by multiple vulnerabilities.

Description

The version of Google Chrome installed on the remote Mac OS X host is prior to 47.0.2526.73. It is, therefore, affected by multiple vulnerabilities :

- An out-of-bounds access error exists in Google V8 that is triggered when loading array elements. An attacker can exploit this to have an unspecified impact.
(CVE-2015-6764)

- A use-after-free error exists that is triggered when handling updates. An unauthenticated, remote attacker can exploit this to dereference already freed memory, resulting in the execution of arbitrary code.
(CVE-2015-6765)

- A use-after-free error exists in AppCache that is triggered when handling updates. An unauthenticated, remote attacker can exploit this to dereference already freed memory, resulting in the execution of arbitrary code. (CVE-2015-6766)

- A use-after-free error exists in the OnChannelConnected() function. An unauthenticated, remote attacker can exploit this to dereference already freed memory, resulting in the execution of arbitrary code. (CVE-2015-6767)

- A same-origin bypass vulnerability exists due to a flaw that is triggered when handling 'javascript:' URI document navigations during page dismissal events. An attacker can exploit this to bypass the same-origin policy. (CVE-2015-6768)

- A same-origin bypass vulnerability exists due to a flaw that is triggered when committing a provisional load and handling the window proxy. An attacker can exploit this to bypass the same-origin policy. (CVE-2015-6769)

- A same-origin bypass vulnerability exists due to a flaw in DOM. An attacker can exploit this to bypass the same-origin policy. (CVE-2015-6770)

- An out-of-bounds access error exists in Google V8 related Map and Filter array construction. An attacker can exploit this to have an unspecified impact.
(CVE-2015-6771)

- A same-origin bypass vulnerability exists due to a flaw that is triggered when navigating to a 'javascript:' URI and detaching the document. An attacker can exploit this to bypass the same-origin policy. (CVE-2015-6772)

- An out-of-bounds access error exists in Google Skia related to the handling of rows. An attacker can exploit this to have an unspecified impact. (CVE-2015-6773)

- A use-after-free error exists in the GetLoadTimes() function. An unauthenticated, remote attacker can exploit this to dereference already freed memory, resulting in the execution of arbitrary code.
(CVE-2015-6774)

- A type confusion error exists in Google PDFium. An unauthenticated, remote attacker can exploit this to execute arbitrary code. (CVE-2015-6775)

- An heap-based overflow condition exists in OpenJPEG in the opj_dwt_decode() function due to improper validation of user-supplied input. An unauthenticated, remote attacker can exploit this to cause a denial of service condition or the execution of arbitrary code.
(CVE-2015-6776)

- A use-after-free error exists in the notifyNodeInsertedInternal() function. An unauthenticated, remote attacker can exploit this to dereference already freed memory, resulting in the execution of arbitrary code. (CVE-2015-6777)

- An out-of-bounds access error exists in Google PDFium.
An attacker can exploit this to have an unspecified impact. (CVE-2015-6778)

- A security bypass vulnerability exists in Google PDFium due to improper restriction of certain URLs (e.g. allows working links to 'chrome://'). An attacker can exploit this to bypass intended access restrictions.
(CVE-2015-6779)

- A use-after-free error exists that is triggered when handling the origin info bubble. An unauthenticated, remote attacker can exploit this to dereference already freed memory, resulting in the execution of arbitrary code. (CVE-2015-6780)

- An integer overflow condition exists in Google sfntly due to improper validation of user-supplied input. An attacker can exploit this to have an unspecified impact.
(CVE-2015-6781)

- A content spoofing vulnerability exists due to a flaw in the Document::open() function that is triggered when handling page dismissal events. An attacker can exploit this to spoof omnibox content. (CVE-2015-6782)

- A security bypass vulnerability exists in Google Android Crazy Linker that is triggered when searching for the zip EOCD record signature. An attacker can exploit this to bypass signature validation. (CVE-2015-6783)

- A flaw exists that is triggered as '--' in the page URL is not escaped by the page serializer when saving pages.
An attacker can exploit this to inject text that is treated as HTML content. (CVE-2015-6784)

- A security bypass vulnerability exists that is triggered when matching Content Security Policy (CSP) source lists containing wildcards. An attacker can exploit this to bypass CSP restrictions. (CVE-2015-6785)

- A security bypass vulnerability exists due to a flaw that is triggered when matching 'data:', 'blob:', and 'filesystem:' URIs against wildcards. An attacker can exploit this to bypass CSP restrictions. (CVE-2015-6786)

- Multiple unspecified flaws exist that allow an unauthenticated, remote attacker to execute arbitrary code. (CVE-2015-6787)

Solution

Upgrade to Google Chrome 47.0.2526.73 or later.

See Also

http://www.nessus.org/u?77759993

Plugin Details

Severity: Critical

ID: 87207

File Name: macosx_google_chrome_47_0_2526_73.nasl

Version: 1.7

Type: local

Agent: macosx

Published: 2015/12/04

Updated: 2019/11/20

Dependencies: 70890

Risk Information

Risk Factor: Critical

VPR Score: 6.7

CVSS Score Source: CVE-2015-6787

CVSS v2.0

Base Score: 10

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:google:chrome

Required KB Items: MacOSX/Google Chrome/Installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2015/12/01

Vulnerability Publication Date: 2015/12/01

Reference Information

CVE: CVE-2015-6764, CVE-2015-6765, CVE-2015-6766, CVE-2015-6767, CVE-2015-6768, CVE-2015-6769, CVE-2015-6770, CVE-2015-6771, CVE-2015-6772, CVE-2015-6773, CVE-2015-6774, CVE-2015-6775, CVE-2015-6776, CVE-2015-6777, CVE-2015-6778, CVE-2015-6779, CVE-2015-6780, CVE-2015-6781, CVE-2015-6782, CVE-2015-6783, CVE-2015-6784, CVE-2015-6785, CVE-2015-6786, CVE-2015-6787