LibreOffice < 4.4.6 / 5.x < 5.0.1 Document Bookmark Arbitrary Code Execution

High Nessus Plugin ID 86901


The remote host has an application installed that is affected by an arbitrary code execution vulnerability.


The version of LibreOffice installed on the remote Windows host is prior to 4.4.6 or 5.x prior to 5.0.1. It is, therefore, affected by a memory corruption issue in 'filter/ww8/ww8scan.cxx' due to improper validation of user-supplied input when handling bookmark status positions. A remote attacker can exploit this, via a specially crafted document, to cause a denial of service condition or the execution of arbitrary code.

Note that Nessus has not attempted to exploit this issue but has instead relied only on the application's self-reported version number.


Upgrade to LibreOffice version 4.4.6 ( / 5.0.1 ( or later.

See Also

Plugin Details

Severity: High

ID: 86901

File Name: libreoffice_501.nasl

Version: $Revision: 1.7 $

Type: local

Agent: windows

Family: Windows

Published: 2015/11/17

Modified: 2016/11/23

Dependencies: 55573

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/a:libreoffice:libreoffice

Required KB Items: installed_sw/LibreOffice, SMB/Registry/Enumerated

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2015/09/27

Vulnerability Publication Date: 2015/11/05

Reference Information

CVE: CVE-2015-5214

OSVDB: 129859