LibreOffice < 4.4.5 Multiple Vulnerabilities

High Nessus Plugin ID 86900

Synopsis

The remote host has an application installed that is affected by multiple vulnerabilities.

Description

The version of LibreOffice installed on the remote Windows host is prior to 4.4.5. It is, therefore, affected by the following vulnerabilities :

- An information disclosure vulnerability exists due to the use of stored LinkUpdateMode configuration information in OpenDocument Format files and templates when handling links. A remote attacker can exploit this, via a specially crafted ODF document, to to obtain sensitive information. (CVE-2015-4551)

- An integer underflow condition exists in the ReadJobSetup() function due to improper validation of user-supplied input when handling printer settings. A remote attacker can exploit this, via specially crafted PrinterSetup data in an ODF document, to cause a denial of service condition or the execution of arbitrary code.
(CVE-2015-5212)

- An integer underflow condition exists in the WW8ScannerBase::OpenPieceTable() function due to improper validation of user-supplied input when handling the PieceTable counter. A remote attacker can exploit this, via a specially crafted .DOC file, to cause a denial of service condition or the execution of arbitrary code. (CVE-2015-5213)

Note that Nessus has not attempted to exploit these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to LibreOffice version 4.4.5 (4.4.5.2) or later.

See Also

http://www.nessus.org/u?cdf2c164

http://www.nessus.org/u?8a5c0096

http://www.nessus.org/u?1b2d335c

http://listarchives.documentfoundation.org/www/announce/msg00241.html

Plugin Details

Severity: High

ID: 86900

File Name: libreoffice_445.nasl

Version: 1.8

Type: local

Agent: windows

Family: Windows

Published: 2015/11/17

Updated: 2018/07/12

Dependencies: 55573

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:libreoffice:libreoffice

Required KB Items: installed_sw/LibreOffice, SMB/Registry/Enumerated

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/07/30

Vulnerability Publication Date: 2015/11/05

Reference Information

CVE: CVE-2015-4551, CVE-2015-5212, CVE-2015-5213