nginx 1.9.x < 1.9.6 HTTPv2 PRI Double-Free DoS

High Nessus Plugin ID 86884


The remote web server is affected by a denial of service vulnerability.


According to the self-reported version in its response header, the version of nginx hosted on the remote web server is 1.9.x prior to 1.9.6. It is, therefore, affected by a denial of service vulnerability due to a double-free memory error in the HTTPv2 module that is triggered when handling certain PRI packets. An unauthenticated, remote attacker can exploit this, via a crafted RPI packet, to cause a section of heap-based memory to be freed twice, which can result in crashing the server.


Upgrade to nginx version 1.9.6 or later.

See Also

Plugin Details

Severity: High

ID: 86884

File Name: nginx_1_9_5.nasl

Version: $Revision: 1.4 $

Type: remote

Family: Web Servers

Published: 2015/11/16

Modified: 2018/01/29

Dependencies: 106375

Risk Information

Risk Factor: High


Base Score: 7.8

Temporal Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND


Base Score: 7.5

Temporal Score: 6.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:X

Vulnerability Information

CPE: cpe:/a:igor_sysoev:nginx

Required KB Items: Settings/ParanoidReport, installed_sw/nginx

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2015/10/27

Vulnerability Publication Date: 2015/10/29

Reference Information

OSVDB: 129558