Atlassian Bamboo 2.2.x < 5.8.5 / 5.9.x < 5.9.7 Unspecified Resource Deserialization RCE

high Nessus Plugin ID 86721

Synopsis

The remote web application is affected by a remote code execution vulnerability.

Description

According to its self-reported version number, the instance of Atlassian Bamboo running on the remote host is version 2.2.x prior to 5.8.5 or 5.9.x prior to 5.9.7. It is, therefore, affected by an unspecified resource deserialization flaw due to improper validation of user-supplied input. An unauthenticated, remote attacker can exploit this to execute arbitrary Java code. Note that the attacker must be able to access the Bamboo web interface.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Atlassian Bamboo version 5.8.5 / 5.9.7 or later.

See Also

http://www.nessus.org/u?70364dac

https://jira.atlassian.com/browse/BAM-16439

Plugin Details

Severity: High

ID: 86721

File Name: bamboo_5_8_5.nasl

Version: 1.9

Type: remote

Family: CGI abuses

Published: 11/4/2015

Updated: 6/4/2024

Configuration: Enable thorough checks

Supported Sensors: Nessus

Risk Information

VPR

Risk Factor: High

Score: 7.4

CVSS v2

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 5.4

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

CVSS Score Source: CVE-2015-6576

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 8.2

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:atlassian:bamboo

Required KB Items: installed_sw/bamboo

Excluded KB Items: Settings/disable_cgi_scanning

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 10/21/2015

Vulnerability Publication Date: 10/21/2015

Exploitable With

Core Impact

Reference Information

CVE: CVE-2015-6576

BID: 77292