GLSA-201510-05 : MediaWiki: Multiple vulnerabilities

High Nessus Plugin ID 86690

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-201510-05 (MediaWiki: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in MediaWiki. Please review the CVE identifiers referenced below for details.
Impact :

A remote attacker may be able to create a Denial of Service condition, obtain sensitive information, bypass security restrictions, and inject arbitrary web script or HTML.
Workaround :

There is no known workaround at this time.

Solution

All MediaWiki 1.25 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=www-apps/mediawiki-1.25.2' All MediaWiki 1.24 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=www-apps/mediawiki-1.24.3' All MediaWiki 1.23 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=www-apps/mediawiki-1.23.10'

See Also

https://security.gentoo.org/glsa/201510-05

Plugin Details

Severity: High

ID: 86690

File Name: gentoo_GLSA-201510-05.nasl

Version: Revision: 2.1

Type: local

Published: 2015/11/02

Updated: 2015/11/02

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:mediawiki, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2015/10/31

Reference Information

CVE: CVE-2015-2931, CVE-2015-2932, CVE-2015-2933, CVE-2015-2934, CVE-2015-2935, CVE-2015-2936, CVE-2015-2937, CVE-2015-2938, CVE-2015-2939, CVE-2015-2940, CVE-2015-2941, CVE-2015-2942, CVE-2015-6728, CVE-2015-6729, CVE-2015-6730, CVE-2015-6731, CVE-2015-6732, CVE-2015-6733, CVE-2015-6734, CVE-2015-6735, CVE-2015-6736, CVE-2015-6737

GLSA: 201510-05