Juniper Junos Multiple Python Privilege Escalation (JSA10695)

High Nessus Plugin ID 86605


The remote device is missing a vendor-supplied security patch.


According to its self-reported version number, the remote Juniper Junos device is potentially affected by multiple unspecified flaws related to Python. A local attacker can exploit these to run arbitrary Python code and thus gain elevated privileges.


Apply the relevant Junos software release referenced in Juniper advisory JSA10695.

See Also

Plugin Details

Severity: High

ID: 86605

File Name: juniper_jsa10695.nasl

Version: $Revision: 1.6 $

Type: combined

Published: 2015/10/26

Modified: 2017/05/16

Dependencies: 55932

Risk Information

Risk Factor: High


Base Score: 7.2

Temporal Score: 5.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/o:juniper:junos

Required KB Items: Host/Juniper/JUNOS/Version, Host/Juniper/model

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/10/14

Vulnerability Publication Date: 2015/10/14

Reference Information

CVE: CVE-2014-6448

OSVDB: 128907

JSA: JSA10695