Debian DSA-3377-1 : mysql-5.5 - security update

High Nessus Plugin ID 86580

Synopsis

The remote Debian host is missing a security-related update.

Description

Several issues have been discovered in the MySQL database server. The vulnerabilities are addressed by upgrading MySQL to the new upstream version 5.5.46. Please see the MySQL 5.5 Release Notes and Oracle's Critical Patch Update advisory for further details :

- https://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5
-45.html
- https://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5
-46.html

- http://www.oracle.com/technetwork/topics/security/cpuoct 2015-2367953.html

Solution

Upgrade the mysql-5.5 packages.

For the oldstable distribution (wheezy), these problems have been fixed in version 5.5.46-0+deb7u1.

For the stable distribution (jessie), these problems have been fixed in version 5.5.46-0+deb8u1.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=802564

https://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-45.html

https://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-46.html

http://www.nessus.org/u?404a1fb9

https://packages.debian.org/source/wheezy/mysql-5.5

https://packages.debian.org/source/jessie/mysql-5.5

https://www.debian.org/security/2015/dsa-3377

Plugin Details

Severity: High

ID: 86580

File Name: debian_DSA-3377.nasl

Version: 2.3

Type: local

Agent: unix

Published: 2015/10/26

Updated: 2018/11/13

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.2

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:mysql-5.5, cpe:/o:debian:debian_linux:7.0, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2015/10/24

Reference Information

CVE: CVE-2015-4792, CVE-2015-4802, CVE-2015-4815, CVE-2015-4816, CVE-2015-4819, CVE-2015-4826, CVE-2015-4830, CVE-2015-4836, CVE-2015-4858, CVE-2015-4861, CVE-2015-4870, CVE-2015-4879, CVE-2015-4913

DSA: 3377