MySQL Enterprise Monitor 2.3.x < 2.3.21 / 3.0.x < 3.0.23 Multiple Vulnerabilities

high Nessus Plugin ID 86548
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


A web application running on the remote host is affected by multiple vulnerabilities.


According to its self-reported version, the MySQL Enterprise Monitor application running on the remote host is 2.3.x prior to 2.3.21 or 3.0.x prior to 3.0.23. It is, therefore, potentially affected by multiple vulnerabilities :

- An invalid read error exists in the ASN1_TYPE_cmp() function due to improperly performed boolean-type comparisons. A remote attacker can exploit this, via a crafted X.509 certificate to an endpoint that uses the certificate-verification feature, to cause an invalid read operation, resulting in a denial of service.

- A denial of service vulnerability exists in the libcurl library due to a failure by the fix_hostname() function to properly calculate an index. An unauthenticated, remote attacker can exploit this, via a zero-length host name, to cause a denial of service or possibly have other unspecified impact. (CVE-2015-3144)


Upgrade to MySQL Enterprise Monitor version 2.3.21 / 3.0.23 or later.

See Also

Plugin Details

Severity: High

ID: 86548

File Name: mysql_enterprise_monitor_3_0_23.nasl

Version: 1.12

Type: remote

Family: CGI abuses

Published: 10/22/2015

Updated: 1/19/2021

Dependencies: mysql_enterprise_monitor_web_detect.nasl

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2015-3144


Risk Factor: Medium

Score: 5.9


Risk Factor: High

Base Score: 9

Temporal Score: 6.7

Vector: AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mysql:enterprise_monitor

Required KB Items: installed_sw/MySQL Enterprise Monitor, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 7/31/2015

Vulnerability Publication Date: 3/16/2015

Reference Information

CVE: CVE-2015-0286, CVE-2015-3144

BID: 73225, 74300