Debian DSA-3374-1 : postgresql-9.4 - security update

Medium Nessus Plugin ID 86447

Synopsis

The remote Debian host is missing a security-related update.

Description

Several vulnerabilities have been found in PostgreSQL-9.4, a SQL database system.

- CVE-2015-5288 Josh Kupershmidt discovered a vulnerability in the crypt() function in the pgCrypto extension. Certain invalid salt arguments can cause the server to crash or to disclose a few bytes of server memory.

- CVE-2015-5289 Oskari Saarenmaa discovered that json or jsonb input values constructed from arbitrary user input can crash the PostgreSQL server and cause a denial of service.

Solution

Upgrade the postgresql-9.4 packages.

For the stable distribution (jessie), these problems have been fixed in version 9.4.5-0+deb8u1.

See Also

https://security-tracker.debian.org/tracker/CVE-2015-5288

https://security-tracker.debian.org/tracker/CVE-2015-5289

https://packages.debian.org/source/jessie/postgresql-9.4

https://www.debian.org/security/2015/dsa-3374

Plugin Details

Severity: Medium

ID: 86447

File Name: debian_DSA-3374.nasl

Version: 2.7

Type: local

Agent: unix

Published: 2015/10/20

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:postgresql-9.4, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2015/10/19

Reference Information

CVE: CVE-2015-5288, CVE-2015-5289

DSA: 3374