MS15-110: Security Updates for Microsoft Office to Address Remote Code Execution (3096440) (Mac OS X)

High Nessus Plugin ID 86382


An application installed on the remote Mac OS X host is affected by multiple remote code execution vulnerabilities.


The remote Mac OS X host has a version of Microsoft Office installed that is affected by multiple remote code execution vulnerabilities due to improper handling of objects in memory. A remote attacker can exploit these vulnerabilities by convincing a user to open a specially crafted file in Microsoft Office, resulting in the execution of arbitrary code in the context of the current user.


Microsoft has released patches for Office for Mac 2011 and for Office 2016 for Mac.

See Also

Plugin Details

Severity: High

ID: 86382

File Name: macosx_ms15-110_office.nasl

Version: $Revision: 1.9 $

Type: local

Agent: macosx

Published: 2015/10/14

Modified: 2017/08/30

Dependencies: 86383

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:microsoft:office:2011:mac, cpe:/a:microsoft:office:2016:mac, cpe:/a:microsoft:excel_for_mac:2011, cpe:/a:microsoft:excel_for_mac:2016

Required KB Items: Host/MacOSX/Version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/10/13

Vulnerability Publication Date: 2015/10/13

Reference Information

CVE: CVE-2015-2555, CVE-2015-2558

OSVDB: 128822, 128824

MSFT: MS15-110

MSKB: 3097264, 3097266