Cisco AnyConnect Secure Mobility Client 3.x < 3.1.11004.0 / 4.x < 4.1.6020.0 Privilege Escalation

High Nessus Plugin ID 86302


The remote host is affected by a privilege escalation vulnerability.


The Cisco AnyConnect Secure Mobility Client installed on the remote host is version 3.x prior to 3.1.11004.0 or 4.x prior to 4.1.6020.0.
It is, therefore, affected by an untrusted search path flaw in the CMainThread::launchDownloader method due to a failure to check the path to the downloader application and associated DLL files. An authenticated, local attacker can exploit this, via running the downloader application from outside its expected location and providing crafted DLLs, to execute arbitrary commands on the host with privileges equivalent to the SYSTEM account.

Note that this vulnerability resulted from an incomplete fix for CVE-2015-4211.


Upgrade to Cisco AnyConnect Secure Mobility Client version 3.1.11004.0 / 4.1.6020.0 or later.

See Also

Plugin Details

Severity: High

ID: 86302

File Name: cisco_anyconnect_4_1_6020.nasl

Version: $Revision: 1.3 $

Type: local

Agent: windows

Family: Windows

Published: 2015/10/06

Modified: 2017/04/27

Dependencies: 54953

Risk Information

Risk Factor: High


Base Score: 7.2

Temporal Score: 6.5

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:U/RC:ND

Vulnerability Information

CPE: cpe:/a:cisco:anyconnect_secure_mobility_client

Required KB Items: installed_sw/Cisco AnyConnect Secure Mobility Client, SMB/Registry/Enumerated

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2015/09/22

Vulnerability Publication Date: 2015/09/22

Reference Information

CVE: CVE-2015-6305

OSVDB: 127894


EDB-ID: 38289