Ubuntu 14.04 LTS : lxc regression (USN-2753-2)

High Nessus Plugin ID 86218


The remote Ubuntu host is missing a security-related patch.


USN-2753-1 fixed a vulnerability in LXC. The update caused a regression that prevented some containers from starting. This regression only affected containers that had an absolute path specified as a bind mount target in their configuration file. This update fixes the problem.

We apologize for the inconvenience.

Roman Fiedler discovered a directory traversal flaw in lxc-start. A local attacker with access to an LXC container could exploit this flaw to run programs inside the container that are not confined by AppArmor or expose unintended files in the host to the container.

Note that Tenable Network Security has extracted the preceding description block directly from the Ubuntu security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected lxc package.

Plugin Details

Severity: High

ID: 86218

File Name: ubuntu_USN-2753-2.nasl

Version: $Revision: 2.2 $

Type: local

Agent: unix

Published: 2015/10/01

Modified: 2016/05/24

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:canonical:ubuntu_linux:lxc, cpe:/o:canonical:ubuntu_linux:14.04

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Patch Publication Date: 2015/09/30

Reference Information

USN: 2753-2