GLSA-201507-16 : Portage: Man-in-the-middle attack

High Nessus Plugin ID 86085


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201507-16 (Portage: Man-in-the-middle attack)

Portage does not verify X.509 SSL certificates properly if HTTPS is used.
Impact :

A remote attacker can spoof servers and modify binary package lists via specially crafted certificates.
Workaround :

There is no known workaround at this time.


All Portage users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=sys-apps/portage-'

See Also

Plugin Details

Severity: High

ID: 86085

File Name: gentoo_GLSA-201507-16.nasl

Version: $Revision: 2.1 $

Type: local

Published: 2015/09/23

Modified: 2015/09/23

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:portage, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2015/07/10

Reference Information

CVE: CVE-2013-2100

BID: 59878

GLSA: 201507-16